# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[^\sGWDF](?!.?4)[0-9DTSRF]+//g;t' <<< "G4 G4 G7 G9 G9 R3 B4 RD2 R3 YD2 R4 R5 RR W BDT Y0 YS G8 WDF
R3 RD2 R3 YD2 R5 RR BDT Y0 YS"