$re = '/^#\s*([^:]+?)\s*:\s*(.*?)\s*$/m';
$str = '#Property Name : Property Value
#foo bar : stackoverflow
foo not bar : test
# bang : ding ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);