$re = '/.+?(?=AA)/';
$str = '354858 Some String That Is Important AA OTHER STUFF SOMESTUFF THAT SHOULD BE IGNORED
543788 Another String That Is Important AA OTHER STUFF SOMESTUFF THAT SHOULD BE IGNORED
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);