#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "#\b.*?\b#|\B#\w+"
Local $sString = "Case 1 :" & @CRLF & _
"" & @CRLF & _
"Hello, #how are you# today. " & @CRLF & _
"In this case, I want to detect how are you. Now if there is only a word, then the above case is to be ignored." & @CRLF & _
"" & @CRLF & _
"Case 2 :" & @CRLF & _
"" & @CRLF & _
"Hello, #how are you #today. "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")