use strict;
my $str = 'Case 1 :
Hello, #how are you# today.
In this case, I want to detect how are you. Now if there is only a word, then the above case is to be ignored.
Case 2 :
Hello, #how are you #today. ';
my $regex = qr/#\b.*?\b#|\B#\w+/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}