// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"#\b.*?\b#|\B#\w+").unwrap();
let string = "Case 1 :
Hello, #how are you# today.
In this case, I want to detect how are you. Now if there is only a word, then the above case is to be ignored.
Case 2 :
Hello, #how are you #today. ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}