using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a(?=[^>]*?rel=nofollow)(?=[^>]*?href=""http:\/\/www\.mysite\.com\/.*?"")[^>]*?>";
string input = @"<a .rel=nofollow .. href=""http://www.mysite.com/xyz...."" ... >
<a . .. href=""huntoffice.ie"" ..rel=nofollow. >
<a...> rel=nofollow href=""http://www.mysite.com/""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}