re = /<a(?=[^>]*?rel=nofollow)(?=[^>]*?href="http:\/\/www\.mysite\.com\/.*?")[^>]*?>/
str = '<a .rel=nofollow .. href="http://www.mysite.com/xyz...." ... >
<a . .. href="huntoffice.ie" ..rel=nofollow. >
<a...> rel=nofollow href="http://www.mysite.com/"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end