# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(['-]\b[a-zA-Z])|(\b[a-zA-Z])/$1$2/gm;t' <<< "i'm some text
this-should not match"