#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(['-]\b[a-zA-Z])|(\b[a-zA-Z])"
Local $sString = "i'm some text" & @CRLF & _
"this-should not match"
Local $sSubst = "$1$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)