$re = '/([\'-]\b[a-zA-Z])|(\b[a-zA-Z])/m';
$str = 'i\'m some text
this-should not match';
$subst = "$1$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;