package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?is)(<div[^>]*>(?:\g<1>|.)*?<\/div>)`)
var str = `<body>
<article>
<img src="image.png">
<div class="menu">
<div>
<div>
<div></div>
</div>
</div>
</div>
<p></p>
<div>
<div></div>
</div>
<!--- some elements -->
</article>
<footer>
<!--- some elements -->
</footer>
</body>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}