const regex = /(<div[^>]*>(?:\g<1>|.)*?<\/div>)/gis;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<div[^>]*>(?:\\g<1>|.)*?<\\\/div>)', 'gis')
const str = `<body>
<article>
<img src="image.png">
<div class="menu">
<div>
<div>
<div></div>
</div>
</div>
</div>
<p></p>
<div>
<div></div>
</div>
<!--- some elements -->
</article>
<footer>
<!--- some elements -->
</footer>
</body>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}