$re = '/(<div[^>]*>(?:\g<1>|.)*?<\/div>)/is';
$str = '<body>
<article>
<img src="image.png">
<div class="menu">
<div>
<div>
<div></div>
</div>
</div>
</div>
<p></p>
<div>
<div></div>
</div>
<!--- some elements -->
</article>
<footer>
<!--- some elements -->
</footer>
</body>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);