re = /(<div[^>]*>(?:\g<1>|.)*?<\/div>)/i
str = '<body>
<article>
<img src="image.png">
<div class="menu">
<div>
<div>
<div></div>
</div>
</div>
</div>
<p></p>
<div>
<div></div>
</div>
<!--- some elements -->
</article>
<footer>
<!--- some elements -->
</footer>
</body>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end