// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?is)(<div[^>]*>(?:\g<1>|.)*?<\/div>)").unwrap();
let string = "<body>
<article>
<img src=\"image.png\">
<div class=\"menu\">
<div>
<div>
<div></div>
</div>
</div>
</div>
<p></p>
<div>
<div></div>
</div>
<!--- some elements -->
</article>
<footer>
<!--- some elements -->
</footer>
</body>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}