import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b[AP]M\\W+(?:-\\W+)?([^:\\n]+):";
final String string = "4/16/14, 10:24 AM - John Doe likes your photo\n"
+ "4/16/14, 10:24 AM John Doe replied to your comment\n"
+ "4/16/14, 10:24 AM John Doe: Whats going on\n"
+ "4/16/14, 10:24 AM John Doe: Whats going on : hmmm";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}