use strict;
my $str = '4/16/14, 10:24 AM - John Doe likes your photo
4/16/14, 10:24 AM John Doe replied to your comment
4/16/14, 10:24 AM John Doe: Whats going on
4/16/14, 10:24 AM John Doe: Whats going on : hmmm';
my $regex = qr/\b[AP]M\W+(?:-\W+)?([^:\n]+):/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}