# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(\s+)(.*?) AS ([^,]+)/\1'\3' => '\2'/gm;t' <<< " column1 AS alias1,
column2 AS alias2"