package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\s+)(.*?) AS ([^,]+)`)
var str = ` column1 AS alias1,
column2 AS alias2`
var substitution = "\1'\3' => '\2'"
fmt.Println(re.ReplaceAllString(str, substitution))
}