# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^[+-]?\d{1,3}(?:,\d{3})*(?:[.]\d{2})?$//;t' <<< "0
12
12.123
12,12
12,
123.
12,123,123.88
12,123,123.12456
12125457.22
1,1,1,1
1.1
"