using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[+-]?\d{1,3}(?:,\d{3})*(?:[.]\d{2})?$";
string substitution = @"";
string input = @"0
12
12.123
12,12
12,
123.
12,123,123.88
12,123,123.12456
12125457.22
1,1,1,1
1.1
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}