use strict;
my $str = '0
12
12.123
12,12
12,
123.
12,123,123.88
12,123,123.12456
12125457.22
1,1,1,1
1.1
';
my $regex = qr/^[+-]?\d{1,3}(?:,\d{3})*(?:[.]\d{2})?$/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";