import Foundation
let pattern = #"^[+-]?\d{1,3}(?:,\d{3})*(?:[.]\d{2})?$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
0
12
12.123
12,12
12,
123.
12,123,123.88
12,123,123.12456
12125457.22
1,1,1,1
1.1
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}