# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(te)(?!\w*>)/<mark>$1<\/mark>/g;t' <<< "‘This is a test string’
<cite> — some <test.> wrapped too</cite>"