import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(te)(?!\\w*>)";
final String string = "‘This is a test string’\n"
+ "<cite> — some <test.> wrapped too</cite>";
final String subst = "<mark>$1</mark>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}