import Foundation
let pattern = #"(te)(?!\w*>)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
‘This is a test string’
<cite> — some <test.> wrapped too</cite>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<mark>$1</mark>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)