# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
^ # start of line
(?=(?:.*[A-Z]){2,}) # 2 upper case letters
(?=(?:.*[a-z]){2,}) # 2 lower case letters
(?=(?:.*\d){2,}) # 2 digits
(?=(?:.*[!@#$%^&*()\-_=+{};:,<.>]){2,}) # 2 special characters
(.{8,}) # length 8 or more
$
"""
test_str = ("Valid:\n"
"ABab12!!\n"
"ZZzz11#####\n"
"PAssword12!!\n"
"PassWord12!!\n"
"AA aa 12 ##\n"
"A1#a2Z3z5%\n\n"
"Not Valid:\n"
"AAaa1234\n"
"Password12!!\n"
"Abab12!!\n"
"ZZzz11#\n"
"password12!!\n"
"Password12!!\n"
"AAAa12##\n"
"A1 a2Z3z5%\n\n\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE | re.VERBOSE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.