use strict;
my $str = 'Hashtags
#hashtag text
#hashtag
text #hashtag
text #1tag
text.#hashtag
text #hashtag
text #hashtag!
text #hashtag1 #hashtag2
text #hash_tagüäö
text #hash0tag
text #hash_tag
Hashtags non-ACSII
#хэш_тег
#中英字典
#الأبجدية
Not hashtags
text #1234 # Match! Because we use simplistic version. Need to further filter out.
&#nbsp;
text#hashtag
';
my $regex = qr/(?:^|_|[^\w&/]+)(?:#|#)([\wÀ-ÖØ-öø-ÿ]+)/uip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}