$re = '/(?:^|_|[^\w&/]+)(?:#|#)([\wÀ-ÖØ-öø-ÿ]+)/ui';
$str = 'Hashtags
#hashtag text
#hashtag
text #hashtag
text #1tag
text.#hashtag
text #hashtag
text #hashtag!
text #hashtag1 #hashtag2
text #hash_tagüäö
text #hash0tag
text #hash_tag
Hashtags non-ACSII
#хэш_тег
#中英字典
#الأبجدية
Not hashtags
text #1234 # Match! Because we use simplistic version. Need to further filter out.
&#nbsp;
text#hashtag
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);