$re = '/^(?(?=99)99(\.0+)?|([1-9]\d?(\.\d+)?))$/m';
$str = '1.00
99.00
0.00
1.25
56.9658
99
99.25
99.00
9.36
99.58
5
98.52
90';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);