re = /\w+,\s*f\s*\.\s*\d\d-\s*\d\d-\s*\d\d\d\d/m
str = 'Smith, John,
f. 25-12-1990
or only first part of below:
Smith, John, f. 25-12-
1990
Smith, John, f. 25-
12-1990'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end