$re = '/foobar/m';
$str = 'foo
foobar
bar
foobar
biff
foobar
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);