// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\{(?:[^{}]|(?R))*\}").unwrap();
let string = "2016-03-21 21:36:20.878 INFO 17512 --- [main] This is going well
ok: [goingwell] => {
\"asd12asd_1231\": {
\"aa\":\"bb\",
\"aaa\":\"bbb\"
}
}
2016-03-21 21:36:30.878 INFO 17512 --- [main] Continue...
2016-03-21 21:36:40.878 INFO 17512 --- [main] Logging ...";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}