import Foundation
let pattern = #"\{(?:[^{}]|(?R))*\}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
2016-03-21 21:36:20.878 INFO 17512 --- [main] This is going well
ok: [goingwell] => {
"asd12asd_1231": {
"aa":"bb",
"aaa":"bbb"
}
}
2016-03-21 21:36:30.878 INFO 17512 --- [main] Continue...
2016-03-21 21:36:40.878 INFO 17512 --- [main] Logging ...
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}