re = /([A-Z]\w*\s)+[A-Z]\w*/m
str = 'One language used for managing databases is Structured Query Language. The language was developed at International Business Machines.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end