# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(PRO\|)(\d+\|)([^|]+\|)\d+\|(.*)$/$1$2$3$2$4/gm;t' <<< "PRO|00000001|GASOLINA ADITIVADA|0101001|27101259|"