use strict;
my $str = 'PRO|00000001|GASOLINA ADITIVADA|0101001|27101259|';
my $regex = qr/^(PRO\|)(\d+\|)([^|]+\|)\d+\|(.*)$/mp;
my $subst = '$1$2$3$2$4';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";