import Foundation
let pattern = #"^(PRO\|)(\d+\|)([^|]+\|)\d+\|(.*)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"PRO|00000001|GASOLINA ADITIVADA|0101001|27101259|"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$2$3$2$4"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)