#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:(?=[a-zA-Z\d]{8})[A-Za-z]+\d*)$"
Local $sString = "abc12345" & @CRLF & _
"w1234567" & @CRLF & _
"qweqr123" & @CRLF & _
"jsgwiuegn1274124" & @CRLF & _
"qwerasdf" & @CRLF & _
"awdjwuadhuf" & @CRLF & _
"" & @CRLF & _
"wrong examples: " & @CRLF & _
"12345678" & @CRLF & _
"qwe12qwe" & @CRLF & _
"12qweqwe" & @CRLF & _
"qweq12"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")