use strict;
my $str = 'abc12345
w1234567
qweqr123
jsgwiuegn1274124
qwerasdf
awdjwuadhuf
wrong examples:
12345678
qwe12qwe
12qweqwe
qweq12';
my $regex = qr/^(?:(?=[a-zA-Z\d]{8})[A-Za-z]+\d*)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}