$re = '/([\s\S]*?)(\S*(\.)\S*)/m';
$str = 'SELECT *
FROM db.table1
UNION ALL
SELECT *
FROM db.table2';
$subst = "$2\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;