re = /(?:[0-9]{1,3}\.){3}[0-9]{1,3}(?=\s|\)|$)/
str = 'Nmap scan report for whm.ixcsoft.com.br (45.174.128.220)
Host is up (0.047s latency).
Nmap scan report for 231.128.174.45.ixcsoft.com.br (45.174.128.231)
Host is up (0.048s latency).
Nmap scan report for 192.168.25.2
Host is up (0.048s latency).
Nmap scan report for 192.168.25.3
Host is up (0.048s latency).'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end