#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^(?<protocol>((https?)|(sftp)|(ftps?):))?(\/\/)?(?<domain>([a-zA-Z0-9\._-]+))+(?<path>([\/\w.]+))*(\?{0,1})(?<parameters>([&|&]*([\w\.,-]*=*[\w\.,-]*)))*$"
Local $sString = "ftp://www.googoogle.com.tw/path/test.aspx?para=abc&def=-123.5"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")