package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(?<protocol>((https?)|(sftp)|(ftps?):))?(\/\/)?(?<domain>([a-zA-Z0-9\._-]+))+(?<path>([\/\w.]+))*(\?{0,1})(?<parameters>([&|&]*([\w\.,-]*=*[\w\.,-]*)))*$`)
var str = `ftp://www.googoogle.com.tw/path/test.aspx?para=abc&def=-123.5`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}