import re
regex = re.compile(r"(0|10)*11(0|1)*")
test_str = ("0100110\n"
"0111\n"
"00010011001\n"
"010101010101\n"
"0000000\n"
"00100000001\n"
"00110000001\n"
"00110000011\n"
"0000000\n"
"1000000\n"
"1100000\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")