#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:(?:(?:0?[13578]|1[02])(\/|-|\.)31)\1|(?:(?:0?[1,3-9]|1[0-2])(\/?|-|\.)(?:29|30)\2))(?:(?:1[6-9]|[2-9]\d)?\d{2})$|^(?:(?:0?2)(\/?|-|\.)(?:29)\3(?:(?:(?:1[6-9]|[2-9]\d)?(?:0[48]|[2468][048]|[13579][26])|(?:(?:16|[2468][048]|[3579][26])00))))$|^(?:(?:0?[1-9])|(?:1[0-2]))(\/?|-|\.)(?:0?[1-9]|1\d|2[0-8])\4(?:(?:1[6-9]|[2-9]\d)?\d{2})$"
Local $sString = "" & @CRLF & _
"12/01/1986" & @CRLF & _
"02/29/2016" & @CRLF & _
"02/29/2015" & @CRLF & _
"13/31/1986" & @CRLF & _
"12/31/1980" & @CRLF & _
"1/32/2015" & @CRLF & _
"1/31/2015" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"01012016" & @CRLF & _
"01/01/2016" & @CRLF & _
"1/1/2016" & @CRLF & _
"1/1/16" & @CRLF & _
"01/01/16" & @CRLF & _
"01-01-2016" & @CRLF & _
"1-1-2016" & @CRLF & _
"1-1-16" & @CRLF & _
"01-01-16" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")