package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`((?:[^,]*,[^,]*|[^,]+){1})(?:,|$)`)
var str = `ABC1,ABCD2,A1,A234B456,C1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}