using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:(?:(?:<[^>]+>)*[^<.\n]*)*\.){2}";
string input = @"<p><img src=""example.image.com"" alt=""foo"">Text. More text.</p>
<p>Text.<img src=""example.image.com"" alt=""foo"">Text. More text.</p>
....
text.
.text.
<...............>.text.<br>text
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}