#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?is)(<a\s+href="http:(?!\/\/(?:www\.)?example\.com)[^"]*")>"
Local $sString = "<a href="/somepage.htm">1</a>" & @CRLF & _
"<a href="http://www.somesiteexternal.com/">2</a>" & @CRLF & _
"<a href="http://www.example.com/somepage.htm">3</a>" & @CRLF & _
""
Local $sSubst = "\1 target="_blank">"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)